电脑技术吧

会员投稿 会员登录 会员注册 网站公告:
搜索: 您现在的位置主页 > 服务器 > Web服务器 > 正文

[图解]Sharepoint 2010开发环境的搭建

作者:admin    文章来源:互联网 电脑技术吧     点击数:    更新时间:2011-09-22
收藏】 【挑错】 【推荐】 【打印
Sharepoint 2010对硬件和软件的要求都挺高的。比如内存要4G,有朋友试了3G/2G, 甚至1.5G内存也可以装一个开发环境的。但是正式运行环境确实是需要至少4G的,最好是8G。

  详细的要求大家可以看MSDN。本文就只列举几个需要注意的地方。

本文来自织梦

  1. 硬件和操作系统须是64位的。 copyright dedecms

   Sharepoint 2007还支持32位的,到2010只支持64位的。最开始的时候碰到的问题是这个64位的问题。颇费了些劲才弄明白。原本操作系统是32位的Windows Server 2008 with SP2,启动了安装程序,出现如下界面: 织梦好,好织梦

安装开始前界面

本文来自织梦

  然后点“安装必备软件”和“安装SharePoint Server”都没有任何反应。也不开始安装,也没有任何提示信息。点击“查看硬件和软件要求”,看了安装要求,MSDN的页面都说了Windows Server 2008 with SP2和Windows Server 2008 R2可以安装,为什么已经是Windows Server 2008 with SP2,点那两个链接没有动静呢(还没有意识到是32位的问题)。不明白。于是在网络上搜索答案,搜来搜去, 找到了微软Sharepoint组的一个Program manager的博客,他解释说Sharepoint只能在64位操作系统上运行。这才明白原因。只好换到64位的系统上。笔者换到了Windows Server 2008 R2。因为有微软社区精英在开心网的组里面问过类似的问题,笔者也回答过。所以这个似乎是个比较普遍的问题。建议MSDN的网页加上64位的字样,或者点击安装程序至少有点信息说不支持32位操作系统云云。不然会继续有更多人困惑。 织梦内容管理系统

  2. Sql Server 2008必须是打了Sp2包的。 copyright dedecms

  最开始Sql Server 2008是没有打Sp包的版本。Sharepoint 2010报Sql Server版本太低。只有下载了Sp2包,安装上以后才解决。这个安装程序的提示信息也不够友好,希望能提示Sql Server 2008须有Sp2版本以上才能安装Sharepoint2010。

织梦好,好织梦

  3. 只有选服务器场模式,才可以指定Sql Server 2008实例,否则就只能用Sharepoint 2010自带的Sql Server Express版安装。

内容来自dedecms

  注意事项交待完毕,说一下安装过程: 本文来自织梦

在Windows Server 2008 R2上启动安装程序,出现上面的图(见上图)。点“安装必备软件”,出现:

织梦好,好织梦

安装必备组件

织梦内容管理系统

点”Next“。安装中: 织梦好,好织梦

必备组件安装中 本文来自织梦

等必备软件安装完成。就可以点“安装Share Point Server”安装SharePoint。

内容来自dedecms

输入产品密钥,如果是试用,可以从MSDN下载页上找到试用密钥。输入即可。

织梦内容管理系统

输入产品密钥

Tags:  
责任编辑:admin
相关文章列表
发表评论 请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
用户名:密码:新注册匿名
评论总数: [ 查看全部 ] 网友评论
关于我们 - 联系我们 - 广告服务 - 友情链接 - 网站地图 - 版权声明 - 人才招聘 - 在线帮助